Техническая страница комментариев о товаре
Frame Theme - быстрый адаптивный шаблон для OpenCart 3 на Bootstrap 4

Текущая страница № 11

Перейти на основную страницу товара вы можете по ссылке



xds
09.05.2021
optimlab, добрый день. Плагин owl-карусельиспользуется за тем, что на мой взгляд это более удачное решение с точки зрения баланса производительности и функционала, чем swiper, а так же он лишен некоторых "болезней", которые присущи свайперу. А вот остальную часть вашего вопроса я не понял. Не знаю что такое "swiper в 1.5". И что значит "предыдущие модули" мне тоже не до конца ясно. Если вы имеете ввиду шаблоны от предыдущих версий модуля, то теоретически должны подойти, но я так по памяти не смогу сказать. Возможно появление ошибок связанных с новым функционалом этих модулей. Нужно проверять.
optimlab
14.05.2021
Я противоположного мнения про swiper и owl, если их сравнивать, особенно swiper 6. Хотелось бы узнать о "болезнях", какие? Так же owl-карусель, не совместима с BS4 из-за дебильных вставок внутренних контейнеров через JS. Не подходят прошлые версии слайдеров, так как вы удалили подключение скриптов swiper в контроллере: // removed by frame theme.
xds
14.05.2021
>> Я противоположного мнения про swiper и owl, если их сравнивать, особенно swiper 6
Это прекрасно, вы как и любой другой человек имеете полное право на своё мнение. Однако в опенкарт по умолчанию используется третья версия этого модуля, а не шестая. А на момент написания этого функционала в шаблоне шестой еще в природе не было
xds
14.05.2021
>> Хотелось бы узнать о "болезнях", какие?
Основной проблемой, заставившей меня сменить плагин были массовые жалобы на необъяснимые фризы при рендеринге каруселей в некоторых браузерах. Второй момент это то что библиотека свапера на тот момент была более тяжелая и менее производительная. Возможно в 6ой версии таких проблем уже нету, я не проверял. Но всё равно я считаю не целесообразным загружать в систему такой мощный и тяжёлый комбайн для решения таких простых задач, как горизонтальная прокрутка товаров и картинок. В будущих обновлениях, в рамках планируемых работ по переходу на bootstrap 5, я планирую заменить этот плагин на еще более лёгкий написанный на нативном js и не зависимый от библиотеки jquery
xds
14.05.2021
>> Так же owl-карусель, не совместима с BS4 из-за дебильных вставок внутренних контейнеров через JS
Смысл этого утверждения мне вообще не ясен, т.к. шаблон работает на фреймворке bs4 и, как вы можете заменить, owl-карусель в шаблоне прекрасно с ним совмещается. Подозреваю что вы просто не до конца разобрались в том как устроен этот плагин, либо я просто не понял что вы имеете ввиду
xds
14.05.2021
>> Не подходят прошлые версии слайдеров, так как вы удалили подключение скриптов swiper в контроллере: // removed by frame theme.
Естественно я отключил загрузку библиотеки, которая не используется. Было бы невероятно глупо ее загружать в систему просто до кучи, при этом седая вычислительные ресурсы, в то время когда люди отчаянно борются за каждый лишний бал в тестах google pagespeed в надежде продвинуться выше в поисковой выдачи. Если вам необходим этот плагин для решения ваших задач, что вам мешает его таким же образом вернуть в систему?

Все права защищены
Магазин дополнений для OpenCart © 2018
Сайт о русской сборке OpenCart | Форум - Русское сообщество OpenCart